torrent/shell.nix
2024-01-13 15:05:52 +00:00

33 lines
566 B
Nix

let
nixpkgs = fetchTarball "https://github.com/NixOS/nixpkgs/tarball/nixos-23.11";
pkgs = import nixpkgs { config = {}; overlays = []; };
in
pkgs.mkShell {
packages = with pkgs; [
git
nushell
mc
jq
deluge
libtorrent-rasterbar
python311Packages.libtorrent-rasterbar
python311Full
python311Packages.ipython
python311Packages.ipdb
python311Packages.rq
rsync
boehmgc
# rustc
# dumptorrent
# udpt
# buildtorrent
];
shellHook = ''
cd $BASE
git status
$BASE/hero_shell.sh
'';
}